summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-01-27 13:07:40 -0500
committerLeo Famulari <leo@famulari.name>2022-01-28 14:03:03 -0500
commit54add2e1ba1a5729fbf5b34854a961edfdd17334 (patch)
tree65987141899f6e404ca6ddc573501bc6d9b21fc5 /gnu
parentdc7ebaf8c7f3a358789fd4d5d7c8ac2197a78e8b (diff)
downloadguix-54add2e1ba1a5729fbf5b34854a961edfdd17334.tar.gz
gnu: qutebrowser: Remove a transitive dependency on QtWebKit.
This browser is explicity a Chromium / QtWebEngine browser, so it shouldn't also
depend on QtWebKit.

See <https://issues.guix.gnu.org/53289> for more information about this change.

* gnu/packages/web-browsers.scm (qutebrowser)[inputs]: Replace python-pyqt with
python-pyqt-without-qtwebkit.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web-browsers.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 5b3ef54659..8e513f01a2 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -487,7 +487,7 @@ interface.")
            ;; FIXME: python-pyqtwebengine needs to come before python-pyqt so
            ;; that it's __init__.py is used first.
            python-pyqtwebengine
-           python-pyqt
+           python-pyqt-without-qtwebkit
            ;; While qtwebengine is provided by python-pyqtwebengine, it's
            ;; included here so we can wrap QTWEBENGINEPROCESS_PATH.
            qtwebengine))