summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-02 09:26:36 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-02 09:26:36 +0100
commit7e75269b8b49579aee6a9e5b2804f6ba257c6039 (patch)
treef26b6683aa0a7393cf467c937e9b09e28ff39e14 /gnu
parentfaa03d1ace931714210b937cefdf8c629b638529 (diff)
downloadguix-7e75269b8b49579aee6a9e5b2804f6ba257c6039.tar.gz
gnu: emacs-evil-traces: Update to 0.2.0.
* gnu/packages/emacs-xyz.scm (emacs-evil-traces): Update to 0.2.0.
[arguments]: Use G-expressions. Remove trailing #T.
[synopsis, description]: Rationalize emphasis and capitalization.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm37
1 files changed, 19 insertions, 18 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d27800b71b..ba29834ae5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28615,11 +28615,12 @@ programming in Emacs Lisp easy and fun.")
     (license license:gpl3+)))
 
 (define-public emacs-evil-traces
-  (let ((commit "1931e3ea2c64b4aec393a9c25063c330deff55e3")
-        (revision "2"))
+  ;; XXX: Upstream does not tag releases.  Use commit matching exact version
+  ;; bump.
+  (let ((commit "05e201cd63b549e3c88b5c3fc9b264bd6fe5a42c"))
     (package
       (name "emacs-evil-traces")
-      (version (git-version "0.0.1" revision commit))
+      (version "0.2.0")
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
@@ -28628,25 +28629,25 @@ programming in Emacs Lisp easy and fun.")
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "12p9lfxscs182vbd4dy0m5gacs3d4kyprbz5yndpwvl8g2qsqplz"))))
+                  "0vadpy2whcgx08blyb4vw6wq3nrxdl03zv85lp37pf3mdk9kwmga"))))
       (build-system emacs-build-system)
+      (arguments
+       (list
+        #:tests? #t
+        #:test-command #~(list "make" "test")
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-after 'unpack 'set-shell
+              ;; Setting the SHELL environment variable is required for the
+              ;; tests to find sh.
+              (lambda _
+                (setenv "SHELL" (which "sh")))))))
       (propagated-inputs
        (list emacs-evil))
-      (arguments
-       `(#:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'set-shell
-             ;; Setting the SHELL environment variable is required for the tests
-             ;; to find sh.
-             (lambda _
-               (setenv "SHELL" (which "sh"))
-               #t)))
-         #:tests? #t
-         #:test-command '("make" "test")))
       (home-page "https://github.com/mamapanda/evil-traces")
-      (synopsis "Visual hints for @code{evil-ex}")
-      (description "This package adds visual hints to certain @code{ex}
-commands in @code{evil-mode}.")
+      (synopsis "Visual hints for Emacs' Evil Ex commands")
+      (description "This package adds visual hints to certain Ex commands in
+Evil mode.")
       (license license:gpl3+))))
 
 (define-public emacs-evil-tmux-navigator