summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-09-28 18:24:38 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-09-30 17:11:32 +0300
commit83dd03f12f1bf4768f7e88ddd324d61d7f93c6ab (patch)
tree81dc4df8301d4debc565201a7e64b8c7449e205f /gnu
parent784f45db065d70a28580c16e7ec4fe10e9e022e9 (diff)
downloadguix-83dd03f12f1bf4768f7e88ddd324d61d7f93c6ab.tar.gz
gnu: Add rust-debugger-test-parser-0.1.
* gnu/packages/crates-io.scm (rust-debugger-test-parser-0.1): New
variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 114a00478d..dec7aa45db 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -17047,6 +17047,31 @@ type.")
 the Debug trait manually.")
     (license license:expat)))
 
+(define-public rust-debugger-test-parser-0.1
+  (package
+    (name "rust-debugger-test-parser")
+    (version "0.1.3")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "debugger-test-parser" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0xcyxw0si7j4h701aksdd08j8jmrzc58833g66wm4xvp592kdrgb"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-anyhow" ,rust-anyhow-1)
+        ("rust-log" ,rust-log-0.4)
+        ("rust-regex" ,rust-regex-1))))
+    (home-page
+     "https://github.com/microsoft/rust_debugger_test/debugger_test_parser")
+    (synopsis "Library for parsing debugger output")
+    (description
+     "This package provides a library for parsing the output of a debugger and
+verifying the contents.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-decimal-2
   (package
     (name "rust-decimal")