summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-28 00:06:30 +0200
committerMarius Bakke <marius@gnu.org>2022-08-30 20:43:02 +0200
commit859509a11c44f61255ffe48a2cdd159ad46b17e7 (patch)
tree35629aeb06ad4685b174334d81e7122f0514c33c /gnu
parent59c136ef611b7a00683af1d1bb406dbd1af1a2bd (diff)
downloadguix-859509a11c44f61255ffe48a2cdd159ad46b17e7.tar.gz
gnu: python-numpy: Avoid usage of 'this-package-input'.
* gnu/packages/python-xyz.scm (python-numpy)[arguments]: Use SEARCH-INPUT-FILE
instead of THIS-PACKAGE-INPUT.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 17df17fa9d..d60b85aced 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5618,7 +5618,10 @@ writing C extensions for Python as easy as Python itself.")
 [openblas]
 libraries = openblas
 library_dirs = ~a/lib
-include_dirs = ~:*~a/include~%" #$(this-package-input "openblas"))))))
+include_dirs = ~:*~a/include~%"
+                          (dirname (dirname
+                                    (search-input-file
+                                     inputs "include/openblas_config.h"))))))))
           (add-before 'build 'fix-executable-paths
             (lambda* (#:key inputs #:allow-other-keys)
               ;; Make /gnu/store/...-bash-.../bin/sh the default shell,