summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-08-11 12:35:21 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-08-11 13:20:19 +0300
commit91c52629e866ee6beb0266252d64254f15e7868d (patch)
tree561a58a6341c1b7965c791fb11e9c4f28453b899 /gnu
parent0ec60d6e0341a99b9cc0af3127fbc14069866520 (diff)
downloadguix-91c52629e866ee6beb0266252d64254f15e7868d.tar.gz
gnu: corkscrew: Use 'modify-phases'.
* gnu/packages/ssh.scm (corkscrew)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ssh.scm33
1 files changed, 16 insertions, 17 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index da6784f2f2..b860d6e924 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -275,23 +275,22 @@ libssh library.")
      ;; Replace configure phase as the ./configure script does not link
      ;; CONFIG_SHELL and SHELL passed as parameters
      '(#:phases
-       (alist-replace
-        'configure
-        (lambda* (#:key outputs inputs system build target
-                        #:allow-other-keys #:rest args)
-          (let* ((configure (assoc-ref %standard-phases 'configure))
-                 (prefix (assoc-ref outputs "out"))
-                 (bash   (which "bash"))
-                 ;; Set --build and --host flags as the provided config.guess
-                 ;; is not able to detect them
-                 (flags `(,(string-append "--prefix=" prefix)
-                          ,(string-append "--build=" build)
-                          ,(string-append "--host=" (or target build)))))
-            (setenv "CONFIG_SHELL" bash)
-            (zero? (apply system* bash
-                          (string-append "." "/configure")
-                          flags))))
-        %standard-phases)))
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key outputs inputs system build target
+                           #:allow-other-keys #:rest args)
+             (let* ((configure (assoc-ref %standard-phases 'configure))
+                    (prefix (assoc-ref outputs "out"))
+                    (bash   (which "bash"))
+                    ;; Set --build and --host flags as the provided config.guess
+                    ;; is not able to detect them
+                    (flags `(,(string-append "--prefix=" prefix)
+                             ,(string-append "--build=" build)
+                             ,(string-append "--host=" (or target build)))))
+               (setenv "CONFIG_SHELL" bash)
+               (zero? (apply system* bash
+                             (string-append "." "/configure")
+                             flags))))))))
     (home-page "http://www.agroman.net/corkscrew")
     (synopsis "Tunneling SSH through HTTP proxies")
     (description