summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-09 23:01:33 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:33:17 +0200
commita5cdcf6c0986653ebb33fca9227e8a61ce37aed9 (patch)
tree9e278ffe08b5311201571168867f86f4bfc11366 /gnu
parent095494ed6c9ba6924c938038dc0fb3ce86f6a1ad (diff)
downloadguix-a5cdcf6c0986653ebb33fca9227e8a61ce37aed9.tar.gz
gnu: Add java-javax-mail.
* gnu/packages/java.scm (java-javax-mail): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 6556ab2718..4793b30538 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2915,6 +2915,32 @@ and contributes the Eclipse default text editor.")
 development tools.")
     (license license:epl1.0)))
 
+(define-public java-javax-mail
+  (package
+    (name "java-javax-mail")
+    (version "1.5.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://repo1.maven.org/maven2/"
+                                  "com/sun/mail/javax.mail/"
+                                  version "/javax.mail-"
+                                  version "-sources.jar"))
+              (sha256
+               (base32
+                "0sdlfgsc2b5s89xv1261y8i0jijcja019k2x1c8ngfn582w4jly9"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:tests? #f ; no tests
+       #:jar-name "javax-mail.jar"))
+    (home-page "https://javamail.java.net")
+    (synopsis "Reference implementation of the JavaMail API")
+    (description
+     "This package provides versions of the JavaMail API implementation, IMAP,
+SMTP, and POP3 service providers, some examples, and documentation for the
+JavaMail API.")
+    ;; GPLv2 only with "classpath exception".
+    (license license:gpl2)))
+
 (define-public java-log4j-api
   (package
     (name "java-log4j-api")