summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 04:04:28 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:44:09 -0400
commitc4fc86e4f8f5184f46f6c18b9c06d4dcc0e143e6 (patch)
treefec150da7919778b33ec3db334f26fc4288ac7e2 /gnu
parentff440d62dc67e6483c65aac470a8fe28bbd54917 (diff)
downloadguix-c4fc86e4f8f5184f46f6c18b9c06d4dcc0e143e6.tar.gz
gnu: texlive-fonts-ec: Remove vestigial error code plumbing.
* gnu/packages/tex.scm (texlive-fonts-ec)[arguments]: Remove vestigial error
code plumbing.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6d3ec93a16..29792cbb21 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2913,16 +2913,17 @@ in SGML; use maths minus in text as appropriate; simple Young tableaux.")
                                       (assoc-ref inputs "texlive-fonts-cm")
                                       "/share/texmf-dist/fonts/source/public/cm")))
              (mkdir "build")
-             (every (lambda (font)
-                      (format #t "building font ~a\n" font)
-                      (invoke "mf" "-progname=mf"
-                              "-output-directory=build"
-                              (string-append "\\"
-                                             "mode:=ljfour; "
-                                             "mag:=1; "
-                                             "batchmode; "
-                                             "input " (basename font ".mf"))))
-                    (find-files "." "[0-9]+\\.mf$"))))
+             (for-each (lambda (font)
+                         (format #t "building font ~a\n" font)
+                         (invoke "mf" "-progname=mf"
+                                 "-output-directory=build"
+                                 (string-append "\\"
+                                                "mode:=ljfour; "
+                                                "mag:=1; "
+                                                "batchmode; "
+                                                "input " (basename font ".mf"))))
+                       (find-files "." "[0-9]+\\.mf$"))
+             #t))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))