summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 15:05:01 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 15:05:01 +0100
commitc5f1f8b81e66b6a63c6bcc173e34e96d9cda9270 (patch)
tree03e812055a7d0cd684633f6e3be9a52b455a14eb /gnu
parent2b37ec1c608f935e183b532e92b973cbb0e8fb1b (diff)
downloadguix-c5f1f8b81e66b6a63c6bcc173e34e96d9cda9270.tar.gz
gnu: Properly deprecate texlive-generic-ulem.
* gnu/packages/python-xyz.scm (python-nbconvert):
* gnu/packages/maths.scm (hypre): Apply deprecation.
* gnu/packages/tex.scm (texlive-generic-ulem): Fix typo in deprecation
command.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/python-xyz.scm2
-rw-r--r--gnu/packages/tex.scm2
3 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1895acd368..9f7c0476ca 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5551,7 +5551,6 @@ set.")
                                              texlive-xcolor
                                              texlive-xypic
                                              texlive-generic-listofitems
-                                             texlive-generic-ulem
                                              texlive-latex-cmap
                                              texlive-latex-colortbl
                                              texlive-latex-etoc
@@ -5574,6 +5573,7 @@ set.")
                                              texlive-latex-tocloft
                                              texlive-latex-upquote
                                              texlive-latex-varwidth
+                                             texlive-ulem
                                              texlive-wasysym
                                              texlive-latex-wrapfig)))))
     (inputs
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 24e7fef494..a8aff94334 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12615,7 +12615,6 @@ time.")
                                         texlive-enumitem
                                         texlive-eurosym
                                         texlive-fonts-rsfs
-                                        texlive-generic-ulem
                                         texlive-generic-iftex
                                         texlive-jknappen
                                         texlive-latex-amsmath
@@ -12638,6 +12637,7 @@ time.")
                                         texlive-tcolorbox
                                         texlive-titling
                                         texlive-tools
+                                        texlive-ulem
                                         texlive-xcolor
                                         texlive-zapfding)))))
     (propagated-inputs
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a6f693a0a5..4fc25ed656 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7843,7 +7843,7 @@ from a typewriter.  The package also offers double and wavy underlining, and
 striking out (line through words) and crossing out (/// over words).")
     (license license:lppl1.3c+)))
 
-(define-deprecated-package texlive-latex-ulem texlive-ulem)
+(define-deprecated-package texlive-generic-ulem texlive-ulem)
 
 (define-public texlive-latex-pgf
   (package