summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2023-05-08 10:11:10 +0300
committer宋文武 <iyzsong@member.fsf.org>2023-05-13 17:54:14 +0800
commitcc47c5277d4aacb7f7cc8538b8c9af5ff3e1a1f9 (patch)
tree930374e5526ff1cc984d11009efe0c541520d865 /gnu
parent1fa30c597b220bc14681ac1463371377af85a323 (diff)
downloadguix-cc47c5277d4aacb7f7cc8538b8c9af5ff3e1a1f9.tar.gz
gnu: ftxui: Build ftxui-benchmark.
* gnu/packages/cpp.scm (ftxui)[native-inputs]: Add benchmark.
[arguments]: Remove #:phases.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cpp.scm17
1 files changed, 3 insertions, 14 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 1a892d7b78..242ea088bb 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -67,6 +67,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages assembly)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages benchmark)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages build-tools)
   #:use-module (gnu packages c)
@@ -2444,23 +2445,11 @@ queues, resource pools, strings, etc.
                 "01h59ln8amsj6ymxmsxhmslld2yp003n82fg3mphgkrh6lf22h6y"))
               (file-name (git-file-name name version))))
     (build-system cmake-build-system)
-    (native-inputs (list googletest))
+    (native-inputs (list googletest benchmark))
     (arguments
      (list #:configure-flags
            #~(list "-DFTXUI_BUILD_TESTS:BOOL=ON"
-                   "-DFTXUI_BUILD_TESTS_FUZZER:BOOL=OFF")
-           #:phases
-           #~(modify-phases %standard-phases
-               (add-after 'unpack 'patch-cmake-tests
-                 (lambda _
-                   (substitute* "cmake/ftxui_test.cmake"
-                     (("NOT googletest_POPULATED")
-                      "FALSE"))
-                   ;; Disable benchmarks for a while as they require bundled Google
-                   ;; benchmark and when the 'googlebenchmark' is unbundled, there's
-                   ;; a CMake configuration error.
-                   ;; TODO: fetch googlebenchmark then renable test
-                   (truncate-file "cmake/ftxui_benchmark.cmake" 0))))))
+                   "-DFTXUI_BUILD_TESTS_FUZZER:BOOL=OFF")))
     (home-page "https://github.com/ArthurSonzogni/FTXUI")
     (synopsis "C++ Functional Terminal User Interface")
     (description