summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-10-07 22:06:24 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-07 22:12:16 +0200
commite052c7e1d5deaaffa0f32fa801508b6316167690 (patch)
tree7c82d61797014819a1b9303c9e7f6fefc70807d5 /gnu
parent2ff746dcd26c21af4cb281074f1a3b6d378ed455 (diff)
downloadguix-e052c7e1d5deaaffa0f32fa801508b6316167690.tar.gz
gnu: gcc@4.8: Use an older Texinfo.
* gnu/packages/gcc.scm (gcc-4.8)[native-inputs]: New field.
(gcc-4.9): Inherit from GCC-4.7.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gcc.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index b1c9b21d82..b26e93e886 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -40,6 +40,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
   #:use-module (guix utils)
+  #:use-module (srfi srfi-1)
   #:use-module (ice-9 regex))
 
 (define %gcc-infrastructure
@@ -328,10 +329,15 @@ Go.  It also includes runtime support libraries for these languages.")
               (sha256
                (base32
                 "08yggr18v373a1ihj0rg2vd6psnic42b518xcgp3r9k81xz1xyr2"))
-              (patches (search-patches "gcc-arm-link-spec-fix.patch"))))))
+              (patches (search-patches "gcc-arm-link-spec-fix.patch"))))
+
+    ;; Texinfo 6.3 fails to build the manual:
+    ;;   ../../gcc-4.8.5/gcc/doc/gcc.texi:208: no matching `@end tex'
+    ;; Use an older one.
+    (native-inputs `(("texinfo" ,texinfo-5)))))
 
 (define-public gcc-4.9
-  (package (inherit gcc-4.8)
+  (package (inherit gcc-4.7)
     (version "4.9.4")
     (source (origin
               (method url-fetch)