summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-08-09 23:36:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-10 15:44:20 +0200
commite7bb12c0a4cb5bf3edb0eefe32d4b4430ebbe672 (patch)
tree1c347b6fecad64e8104cc717763a8d538f11f8b5 /gnu
parent563aabf3ccd52a149fa767f6afba4a0b4ba476f2 (diff)
downloadguix-e7bb12c0a4cb5bf3edb0eefe32d4b4430ebbe672.tar.gz
gnu: Add r-urlchecker.
* gnu/packages/cran.scm (r-urlchecker): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index aef91cb60f..c7aa223388 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18936,6 +18936,27 @@ Minkowski Sum of general polygons.  There is a function for removing
 self-intersections from polygon data.")
     (license license:boost1.0)))
 
+(define-public r-urlchecker
+  (package
+    (name "r-urlchecker")
+    (version "1.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "urlchecker" version))
+              (sha256
+               (base32
+                "06034lb94krbzawqg5xklwcksvyyzl3qy355f66baj5pw7dms5k2"))))
+    (properties `((upstream-name . "urlchecker")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-cli r-curl r-xml2))
+    (home-page "https://github.com/r-lib/urlchecker")
+    (synopsis "Run CRAN URL checks from older R versions")
+    (description
+     "This package provides the URL checking tools available in R 4.1+ as a
+package for earlier versions of R.  It also uses concurrent requests so can be
+much faster than the serial versions.")
+    (license license:gpl3)))
+
 (define-public r-urltools
   (package
     (name "r-urltools")