summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-12 15:25:22 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-13 00:57:52 -0500
commitf787ccca42f1b8acb347892246fc36bc44392712 (patch)
tree0e24235a0fed73235558b87122061df5a5e264b7 /gnu
parent7d6afde74c8668751a8163d8356e52eb207a2193 (diff)
downloadguix-f787ccca42f1b8acb347892246fc36bc44392712.tar.gz
gnu: pjproject: Apply patch to install the libpjsua2 shared library.
* gnu/packages/patches/pjproject-install-libpjsua2.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/telephony.scm (pjproject): Apply it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk3
-rw-r--r--gnu/packages/patches/pjproject-install-libpjsua2.patch19
-rw-r--r--gnu/packages/telephony.scm3
3 files changed, 23 insertions, 2 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 1706663bde..6a9c1b87f9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -19,7 +19,7 @@
 # Copyright © 2018 Amirouche Boubekki <amirouche@hypermove.net>
 # Copyright © 2018, 2019, 2020, 2021 Oleg Pykhalov <go.wigust@gmail.com>
 # Copyright © 2018 Stefan Stefanović <stefanx2ovic@gmail.com>
-# Copyright © 2018, 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+# Copyright © 2018, 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 # Copyright © 2019, 2020, 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
 # Copyright © 2019, 2020 John Soo <jsoo1@asu.edu>
 # Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
@@ -1580,6 +1580,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/pciutils-hurd-configure.patch		\
   %D%/packages/patches/pciutils-hurd-fix.patch			\
   %D%/packages/patches/pitivi-fix-build-with-meson-0.60.patch	\
+  %D%/packages/patches/pjproject-install-libpjsua2.patch	\
   %D%/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch \
   %D%/packages/patches/ppsspp-disable-upgrade-and-gold.patch		\
   %D%/packages/patches/pthreadpool-system-libraries.patch	\
diff --git a/gnu/packages/patches/pjproject-install-libpjsua2.patch b/gnu/packages/patches/pjproject-install-libpjsua2.patch
new file mode 100644
index 0000000000..ef9b0de91f
--- /dev/null
+++ b/gnu/packages/patches/pjproject-install-libpjsua2.patch
@@ -0,0 +1,19 @@
+# Retrieved from upstream:
+# https://github.com/pjsip/pjproject/commit/742f7dc252ded778a8b677937791c02e2fbc0dde
+diff --git a/Makefile b/Makefile
+index 31a6d39d4..74e246a44 100644
+--- a/Makefile
++++ b/Makefile
+@@ -121,9 +121,10 @@ cmp_wav:
+ 
+ install:
+ 	mkdir -p $(DESTDIR)$(libdir)/
+-	cp -af $(APP_LIB_FILES) $(DESTDIR)$(libdir)/
+ 	if [ "$(PJ_EXCLUDE_PJSUA2)x" = "x" ] ; then \
+-	    cp -af $(PJ_DIR)/pjsip/lib/libpjsua2-$(LIB_SUFFIX) $(DESTDIR)$(libdir)/; \
++	    cp -af $(APP_LIBXX_FILES) $(DESTDIR)$(libdir)/; \
++	else \
++	    cp -af $(APP_LIB_FILES) $(DESTDIR)$(libdir)/; \
+ 	fi
+ 	mkdir -p $(DESTDIR)$(includedir)/
+ 	for d in pjlib pjlib-util pjnath pjmedia pjsip; do \
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index eb038c411e..9d384ab166 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -761,7 +761,8 @@ your calls and messages.")
            (substitute* "aconfigure.ac"
              (("third_party/build/os-auto.mak") ""))
            (substitute* "Makefile"
-             (("third_party/build") ""))))))
+             (("third_party/build") ""))))
+       (patches (search-patches "pjproject-install-libpjsua2.patch"))))
     (build-system gnu-build-system)
     (outputs '("out" "debug" "static"))
     (arguments