summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-07-08 04:29:34 -0500
committerLudovic Courtès <ludo@gnu.org>2022-07-19 21:38:45 +0200
commitfce8de7800cb260df358b4715ff52b51d12ebf70 (patch)
tree9b58e042284b19a66ce6486123cbfa72668ee724 /gnu
parentdbf09879710aefe6cedd9ed975cc2b79df01b755 (diff)
downloadguix-fce8de7800cb260df358b4715ff52b51d12ebf70.tar.gz
gnu: Add python-clrprint.
* gnu/packages/python-xyz.scm (python-clrprint): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7f6bbd55be..0ab4755fcc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30093,6 +30093,26 @@ profile.  It supports:
 Currently, Linux is the only platform supported by this library.")
     (license license:expat)))
 
+(define-public python-clrprint
+  (package
+    (name "python-clrprint")
+    (version "2.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "clrprint" version))
+              (sha256
+               (base32
+                "0xfn8d1by2w7pjiji887qljk1avn4fylbnz1mj28gysm5g0zvy43"))))
+    (build-system python-build-system)
+    (arguments '(#:tests? #f))                    ;there are no tests
+    (propagated-inputs (list python-colorama python-termcolor))
+    (home-page "https://github.com/AbhijithAJ/clrprint")
+    (synopsis "Print colorful output in the terminal")
+    (description "@code{clrprint} is developed to print colorful output in the
+terminal.  It has red, blue, green, yellow, purple and black/white (default)
+colors.")
+    (license license:expat)))
+
 (define-public python-musical-scales
   (package
     (name "python-musical-scales")