summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-06-05 01:47:24 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-06-05 09:12:39 +0200
commitfd4fa40ac4cf342e737a95766e7ca28de64f2294 (patch)
treeb66a2dc88677bf91a05964a6d4b02da8df72ff18 /gnu
parentefefb2be3a3992dacbe8a1c9ed210fb4a80331ab (diff)
downloadguix-fd4fa40ac4cf342e737a95766e7ca28de64f2294.tar.gz
gnu: Add r-scaledmatrix.
* gnu/packages/bioconductor.scm (r-scaledmatrix): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index dab37d59de..0302c74ca1 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5647,6 +5647,34 @@ to search for all neighbors within a given distance.  Parallelization is
 achieved for all methods using the BiocParallel framework.")
     (license license:gpl3)))
 
+(define-public r-scaledmatrix
+  (package
+    (name "r-scaledmatrix")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "ScaledMatrix" version))
+       (sha256
+        (base32
+         "1j96fvw1waqxbv5c8myfmhsidq370z03yz13yqmrs4nn1rpn1a06"))))
+    (properties `((upstream-name . "ScaledMatrix")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-delayedarray" ,r-delayedarray)
+       ("r-matrix" ,r-matrix)
+       ("r-s4vectors" ,r-s4vectors)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/LTLA/ScaledMatrix")
+    (synopsis "Create a DelayedMatrix of scaled and centered values")
+    (description
+     "This package provides delayed computation of a matrix of scaled and
+centered values.  The result is equivalent to using the @code{scale} function
+but avoids explicit realization of a dense matrix during block processing.
+This permits greater efficiency in common operations, most notably matrix
+multiplication.")
+    (license license:gpl3)))
+
 (define-public r-biocsingular
   (package
     (name "r-biocsingular")