summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 14:33:56 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 14:33:56 +0100
commit01107fc4eaa928ddd99b834ba8ce7b7244f8c3cd (patch)
treeeafd864d147f58cc71136a89e906b8a2993b4fcc /gnu
parent390f9604110b2f478db73eb5ce8dd3770cb59ea5 (diff)
downloadguix-01107fc4eaa928ddd99b834ba8ce7b7244f8c3cd.tar.gz
gnu: texlive-latex-enumitem: Deprecate package.
* gnu/packages/tex.scm (texlive-latex-enumitem): Deprecate in favor of texlive-enumitem.
* gnu/packages/python-xyz.scm (python-matplotlib-documentation):
(python-nbconvert): Apply deprecation.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm28
-rw-r--r--gnu/packages/tex.scm2
2 files changed, 16 insertions, 14 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c8ba314d38..51a7a64fe6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6543,19 +6543,19 @@ toolkits.")
        ("python-mock" ,python-mock)
        ("graphviz" ,graphviz)
        ("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
-                                        texlive-latex-amsmath
-                                        texlive-latex-enumitem
-                                        texlive-latex-expdlist
-                                        texlive-latex-geometry
-                                        texlive-latex-preview
-                                        texlive-latex-type1cm
-                                        texlive-latex-ucs
-
-                                        texlive-pdftex
-
-                                        texlive-fonts-ec
-                                        texlive-times
-                                        texlive-txfonts)))
+                                             texlive-enumitem
+                                             texlive-latex-amsmath
+                                             texlive-latex-expdlist
+                                             texlive-latex-geometry
+                                             texlive-latex-preview
+                                             texlive-latex-type1cm
+                                             texlive-latex-ucs
+
+                                             texlive-pdftex
+
+                                             texlive-fonts-ec
+                                             texlive-times
+                                             texlive-txfonts)))
        ("texinfo" ,texinfo)
        ,@(package-native-inputs python-matplotlib)))
     (arguments
@@ -12611,13 +12611,13 @@ time.")
                                         texlive-amsfonts
                                         texlive-booktabs
                                         texlive-caption
+                                        texlive-enumitem
                                         texlive-eurosym
                                         texlive-fonts-rsfs
                                         texlive-generic-ulem
                                         texlive-generic-iftex
                                         texlive-jknappen
                                         texlive-latex-amsmath
-                                        texlive-latex-enumitem
                                         texlive-latex-fancyvrb
                                         texlive-latex-float
                                         texlive-fontspec
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cb43a791fc..a6f693a0a5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6163,6 +6163,8 @@ in the form @code{key=value} are available, for example:
 @code{\\begin{itemize}[itemsep=1ex,leftmargin=1cm]}.")
     (license license:lppl1.3+)))
 
+(define-deprecated-package texlive-latex-enumitem texlive-enumitem)
+
 (define-public texlive-latex-multirow
   (package
     (name "texlive-latex-multirow")