summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2016-03-24 14:44:08 +0100
committerAndreas Enge <andreas@enge.fr>2016-03-24 14:44:08 +0100
commit08595262db960b6e680460189bfcfbdac4196b76 (patch)
tree155dc6710bc53f532691efab12de0f2d1839deb2 /gnu
parentf2ab9250283ceb8e36ef90eb1b411a1f5e126f57 (diff)
downloadguix-08595262db960b6e680460189bfcfbdac4196b76.tar.gz
gnu: pari-gp: Syntactic changes.
* gnu/packages/algebra.scm (pari-gp)[arguments]: Use modify-phases syntax.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/algebra.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 11fb460df5..0b291106ad 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -133,17 +133,14 @@ solve the shortest vector problem.")
              ("readline" ,readline)))
    (arguments
     '(#:make-flags '("all")
-      ;; FIXME: building the documentation requires tex; once this is
-      ;; available, replace "gp" by "all"
       #:test-target "dobench"
-      #:phases
-      (alist-replace
-       'configure
-       (lambda* (#:key outputs #:allow-other-keys)
-         (let ((out (assoc-ref outputs "out")))
-           (zero?
-            (system* "./Configure" (string-append "--prefix=" out)))))
-       %standard-phases)))
+      #:phases (modify-phases %standard-phases
+                 (replace 'configure
+                          (lambda* (#:key outputs #:allow-other-keys)
+                           (let ((out (assoc-ref outputs "out")))
+                            (zero?
+                             (system* "./Configure"
+                                      (string-append "--prefix=" out)))))))))
    (synopsis "PARI/GP, a computer algebra system for number theory")
    (description
     "PARI/GP is a widely used computer algebra system designed for fast