summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-11-17 10:46:31 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-11-17 13:05:52 +0200
commit08b6a17de95ba6d26a39218bebd16cc61873505a (patch)
tree08a202450b87ddd9422e6dfcb255c3ac0f9db8e1 /gnu
parent283d7318c5b312d7129adb6dbeea6ad205ce89d1 (diff)
downloadguix-08b6a17de95ba6d26a39218bebd16cc61873505a.tar.gz
gnu: Add lld-15.
* gnu/packages/llvm.scm (lld-15): New variable.
(lld-14): Inherit from lld-15.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/llvm.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index d315149c42..de19b40343 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1519,14 +1519,14 @@ Library.")
     (properties `((release-monitoring-url . ,%llvm-release-monitoring-url)))
     (license license:asl2.0)))          ;with LLVM exceptions
 
-(define-public lld-14
+(define-public lld-15
   (package
     (name "lld")
-    (version "14.0.6")
+    (version "15.0.4")
     (source (llvm-monorepo version))
     (build-system cmake-build-system)
     (inputs
-     (list llvm-14))
+     (list llvm-15))
     (arguments
      '(#:build-type "Release"
        ;; TODO: Tests require the lit tool, which isn't installed by the LLVM
@@ -1542,6 +1542,14 @@ Library.")
 components which highly leverage existing libraries in the larger LLVM Project.")
     (license license:asl2.0))) ; With LLVM exception
 
+(define-public lld-14
+  (package
+    (inherit lld-15)
+    (version "14.0.6")
+    (source (llvm-monorepo version))
+    (inputs
+     (list llvm-14))))
+
 (define-public lld-13
   (package
     (inherit lld-14)