summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-02-15 04:19:28 -0500
committerLeo Famulari <leo@famulari.name>2016-03-18 14:27:16 -0400
commit0efde7d6d6370759f62cb38cc97bd9ee942cb23c (patch)
tree4676fb5037a6d373429b9f4ebbf5879678b4f11c /gnu
parent603d665bc3767f73d4b78f52fb20cf76e21689fc (diff)
downloadguix-0efde7d6d6370759f62cb38cc97bd9ee942cb23c.tar.gz
gnu: Add python-responses.
* gnu/packages/python.scm (python-responses, python2-responses): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9144a37de4..b2b906704f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8314,3 +8314,38 @@ Python.")
     (package (inherit cookies)
       (native-inputs `(("python2-setuptools" ,python2-setuptools)
                        ,@(package-native-inputs cookies))))))
+
+(define-public python-responses
+  (package
+    (name "python-responses")
+    (version "0.5.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "responses" version))
+              (sha256
+               (base32
+                "1spcfxixyk9k7pk82jm6zqkwk031s95lh8q0mz7539jrb7269bcc"))))
+    (build-system python-build-system)
+    (arguments
+     `(;; Test suite is not distributed:
+       ;; https://github.com/getsentry/responses/issues/38
+       #:tests? #f))
+    (native-inputs
+     `(("python-cookies" ,python-cookies)
+       ("python-mock" ,python-mock)))
+    (propagated-inputs
+     `(("python-requests" ,python-requests)
+       ("python-six" ,python-six)))
+    (home-page "https://github.com/getsentry/responses")
+    (synopsis "Utility for mocking out the `requests` Python library")
+    (description "A utility library for mocking out the `requests` Python
+library.")
+    (license asl2.0)
+    (properties `((python2-variant . ,(delay python2-responses))))))
+
+(define-public python2-responses
+  (let ((responses (package-with-python2
+                    (strip-python2-variant python-responses))))
+    (package (inherit responses)
+      (native-inputs `(("python2-setuptools" ,python2-setuptools)
+                       ,@(package-native-inputs responses))))))