summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-05-30 15:37:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-06-01 09:15:26 +0200
commit10d3f8aa7b4962bf56c7d52c183b933b60a4715e (patch)
tree399734c8243b28758ef77ee41371d445444eddf5 /gnu
parent13e2138c230431368ebf32df527f4b5d1e458e4b (diff)
downloadguix-10d3f8aa7b4962bf56c7d52c183b933b60a4715e.tar.gz
gnu: Add r-mbecs.
* gnu/packages/bioconductor.scm (r-mbecs): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7fb7e32b31..a99b6e2b54 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -10118,6 +10118,57 @@ package comprehensively addressing issues ranging from post-alignments
 processing to visualization and annotation.")
     (license license:gpl2)))
 
+(define-public r-mbecs
+  (package
+    (name "r-mbecs")
+    (version "1.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "MBECS" version))
+       (sha256
+        (base32 "0gfr3c5k7xjd342zfdksgh22mrk3ryr4cp89nar0mlpgzxg4l4vz"))))
+    (properties `((upstream-name . "MBECS")))
+    (build-system r-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'set-HOME
+          ;; Fontconfig needs an writable cache
+            (lambda _ (setenv "HOME" "/tmp"))))))
+    (propagated-inputs
+     (list r-cluster
+           r-dplyr
+           r-ggplot2
+           r-gridextra
+           r-limma
+           r-lme4
+           r-lmertest
+           r-magrittr
+           r-markdown
+           r-matrix
+           r-pheatmap
+           r-phyloseq
+           r-rmarkdown
+           r-ruv
+           r-sva
+           r-tibble
+           r-tidyr
+           r-vegan))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/rmolbrich/MBECS")
+    (synopsis
+     "Evaluation and correction of batch effects in microbiome data-sets")
+    (description
+     "The @acronym{MBECS, Microbiome Batch Effect Correction Suite} provides a
+set of functions to evaluate and mitigate unwated noise due to processing in
+batches.  To that end it incorporates a host of batch correcting algorithms
+(BECA) from various packages.  In addition it offers a correction and reporting
+pipeline that provides a preliminary look at the characteristics of a data-set
+before and after correcting for batch effects.")
+    (license license:artistic2.0)))
+
 (define-public r-mbkmeans
   (package
     (name "r-mbkmeans")