summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-22 15:08:02 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-22 15:09:40 +0100
commit11627ca550612843c30944f5bb8cfb74f77ffa3e (patch)
tree0a3be7e80758cc640d4b429a12c8fe8599d498a4 /gnu
parent354d27e5dcf6b946e1ab70d534c8cbde088d3b73 (diff)
downloadguix-11627ca550612843c30944f5bb8cfb74f77ffa3e.tar.gz
gnu: paps: Update to 0.7.0-1.37e6ca1.
* gnu/packages/pdf.scm (paps): Update to 0.7.0-1.37e6ca1.
[source]: Fetch from git.
[arguments]: Add phase "do-not-run-configure-script-during-bootstrap".
[native-inputs]: Add autoconf, automake, gettext-minimal, glib:bin and
intltool.
[home-page]: Point to Github.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/pdf.scm61
1 files changed, 40 insertions, 21 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index b243e6806f..96c0f9e3ad 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -1078,26 +1078,45 @@ presentation.  The input files processed by pdfpc are PDF documents.")
     (license license:gpl2+)))
 
 (define-public paps
-  (package
-    (name "paps")
-    (version "0.6.8")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "mirror://sourceforge/paps/paps/" version "/"
-                           "paps-" version ".tar.gz"))
-       (sha256
-        (base32
-         "080ahnyvq918m8ahq8bg9qvgzlv4k0jgcsdqhrwjzppclx74q8fv"))))
-    (build-system gnu-build-system)
-    (inputs
-     `(("pango" ,pango)))
-    (native-inputs
-     `(("pkg-config" ,pkg-config)))
-    (home-page "http://paps.sourceforge.net/")
-    (synopsis "Pango to PostScript converter")
-    (description
-     "Paps reads a UTF-8 encoded file and generates a PostScript language
+  (let ((commit "37e6ca1cd96d751bbbff5539d795c90d657289a5")
+        (revision "1"))
+    (package
+      (name "paps")
+      ;; The last release was in 2015, but since then there have been security
+      ;; bug fixes.
+      (version (git-version "0.7.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/dov/paps.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1ilcyjqdynxsd2p8dnn8h4592dwf531x9pbkxa1w09hkcdn7hgwc"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'do-not-run-configure-script-during-bootstrap
+             (lambda _
+               (substitute* "autogen.sh"
+                 (("^./configure") "#"))
+               #t)))))
+      (inputs
+       `(("pango" ,pango)))
+      (native-inputs
+       `(("autoconf" ,autoconf)
+         ("automake" ,automake)
+         ("gettext" ,gettext-minimal)
+         ("glib" ,glib "bin")
+         ("intltool" ,intltool)
+         ("pkg-config" ,pkg-config)))
+      (home-page "https://github.com/dov/paps")
+      (synopsis "Pango to PostScript converter")
+      (description
+       "Paps reads a UTF-8 encoded file and generates a PostScript language
 rendering of the file.  The rendering is done by creating outline curves
 through the Pango @code{ft2} backend.")
-    (license license:lgpl2.0+)))
+      (license license:lgpl2.0+))))