summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-02-15 16:15:25 +0000
committerChristopher Baines <mail@cbaines.net>2023-02-15 16:17:14 +0000
commit12127395dc55d9ea389a6dc619207c406725237e (patch)
treec7eee9920c61730d50905f0df4d487c5c65544bf /gnu
parentb4d2670771b8c2b9c4aedbef0371f1d23197d209 (diff)
downloadguix-12127395dc55d9ea389a6dc619207c406725237e.tar.gz
gnu: openmw-openscenegraph: Fix builder.
This broke with the changes to openscenegraph in
629a5936a6dfa0fe2cc2a3092ec51920b216b652.

* gnu/packages/graphics.scm (openmw-openscenegraph)[arguments]: Handle
 #:configure-flags from openscenegraph as a gexp.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 5a50a77a72..94b93970b1 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1492,18 +1492,18 @@ in Julia).")
         (substitute-keyword-arguments (package-arguments openscenegraph)
           ((#:configure-flags flags)
            ;; As per the above wiki link, the following plugins are enough:
-           `(append
-             '("-DBUILD_OSG_PLUGINS_BY_DEFAULT=0"
-               "-DBUILD_OSG_PLUGIN_OSG=1"
-               "-DBUILD_OSG_PLUGIN_DDS=1"
-               "-DBUILD_OSG_PLUGIN_TGA=1"
-               "-DBUILD_OSG_PLUGIN_BMP=1"
-               "-DBUILD_OSG_PLUGIN_JPEG=1"
-               "-DBUILD_OSG_PLUGIN_PNG=1"
-               "-DBUILD_OSG_DEPRECATED_SERIALIZERS=0"
-               ;; The jpeg plugin requires conversion between integers and booleans
-               "-DCMAKE_CXX_FLAGS=-fpermissive")
-             ,flags))))))))
+           #~(append
+              '("-DBUILD_OSG_PLUGINS_BY_DEFAULT=0"
+                "-DBUILD_OSG_PLUGIN_OSG=1"
+                "-DBUILD_OSG_PLUGIN_DDS=1"
+                "-DBUILD_OSG_PLUGIN_TGA=1"
+                "-DBUILD_OSG_PLUGIN_BMP=1"
+                "-DBUILD_OSG_PLUGIN_JPEG=1"
+                "-DBUILD_OSG_PLUGIN_PNG=1"
+                "-DBUILD_OSG_DEPRECATED_SERIALIZERS=0"
+                ;; The jpeg plugin requires conversion between integers and booleans
+                "-DCMAKE_CXX_FLAGS=-fpermissive")
+              #$flags))))))))
 
 (define-public povray
   (package