summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-03-26 15:09:03 -0400
committerMark H Weaver <mhw@netris.org>2014-03-26 21:33:36 -0400
commit15f682f4a3ae8974aad7a2a2fc9079487ca9180a (patch)
tree625b32627401d45b57c2e4dac931ffeeb55074a7 /gnu
parentb3acf3656eafb7b8b75c3eeb7e683ac46c9933bf (diff)
downloadguix-15f682f4a3ae8974aad7a2a2fc9079487ca9180a.tar.gz
gnu: tcl: Install man pages in share/man.
* gnu/packages/tcl.scm (tcl): Add --mandir configure flag.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tcl.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index d025bff72d..18324ec94c 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -56,6 +57,12 @@
                                       "tclsh")))))
                   %standard-phases))
 
+       ;; By default, man pages are put in PREFIX/man,
+       ;; but we want them in PREFIX/share/man.
+       #:configure-flags (list (string-append "--mandir="
+                                              (assoc-ref %outputs "out")
+                                              "/share/man"))
+
        ;; XXX: There are a few test failures (related to HTTP, most
        ;; likely related to name resolution), but that doesn't cause
        ;; `make' to fail.