summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-04-20 08:54:00 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-04-26 10:26:46 +0200
commit1683e9d9677d54f695a54fc44ed309287989fc34 (patch)
tree7dcc23efd2a5ef40c8edabfa74ded637b5ea8c8c /gnu
parent2ff36e418680526a91d9350489f4fc828f5147d3 (diff)
downloadguix-1683e9d9677d54f695a54fc44ed309287989fc34.tar.gz
gnu: Move search path JUPYTER_PATH.
python-jupyter-core provides the `jupyter` binary as well as generic
functions to discover the search path for all Jupyter subprojects. Thus
it should provide the search paths too.

* gnu/packages/python-xyz.scm (jupyter): From here…
(python-jupyter-core): …to here.
[native-search-paths]: Add JUPYTER_CONFIG_DIR, because some Jupyter
projects install config files to their etc/ directory and expect them to
be loaded automatically.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d2e4f92820..a26e005355 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7388,6 +7388,15 @@ without using the configuration machinery.")
     (arguments `(#:tests? #f))
     (propagated-inputs
      `(("python-traitlets" ,python-traitlets)))
+    ;; This package provides the `jupyter` binary and thus also exports the
+    ;; search paths.
+    (native-search-paths
+     (list (search-path-specification
+            (variable "JUPYTER_CONFIG_DIR")
+            (files '("etc/jupyter")))
+           (search-path-specification
+            (variable "JUPYTER_PATH")
+            (files '("share/jupyter")))))
     (home-page "https://jupyter.org/")
     (synopsis "Jupyter base package")
     (description
@@ -10879,10 +10888,6 @@ popular online obfuscators.")
        ("python-nbconvert" ,python-nbconvert)
        ("python-notebook" ,python-notebook)
        ("python-qtconsole" ,python-qtconsole)))
-    (native-search-paths
-     (list (search-path-specification
-            (variable "JUPYTER_PATH")
-            (files '("share/jupyter")))))
     (home-page "https://jupyter.org")
     (synopsis "Web application for interactive documents")
     (description