summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-11-10 01:09:03 +0100
committerLudovic Courtès <ludo@gnu.org>2016-11-12 16:15:08 +0100
commit1e6112d89fd9c43dc040993be6fba0d34e4e9e12 (patch)
treee7e722c07a6cde8f7e172021b1ee209f267ab20d /gnu
parente2fca4906e30c6bd585dfe7dd7dd32b01f15e0d6 (diff)
downloadguix-1e6112d89fd9c43dc040993be6fba0d34e4e9e12.tar.gz
gnu: Add python-rednose.
* gnu/packages/python.scm (python-rednose): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9b3fda1b50..0d3c7aeac9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12180,3 +12180,36 @@ asynchronous messaging environments.")
     (synopsis "Console text coloring for Python")
     (description "This package provides console text coloring for Python.")
     (license license:bsd-3)))
+
+(define-public python-rednose
+  (package
+    (name "python-rednose")
+    (version "1.2.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "rednose" version))
+        (sha256
+          (base32
+            "0b0bsna217lr1nykyhl5fgjly15zhdvqd4prg4wy1zrgfv7al6m0"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-deps
+           (lambda _
+             ;; See <https://github.com/JBKahn/rednose/issues/12>
+             (substitute* "setup.py"
+               (("python-termstyle") "termstyle"))
+             #t)))))
+    (propagated-inputs
+     `(("python-colorama" ,python-colorama)
+       ("python-termstyle" ,python-termstyle)))
+    (native-inputs
+     `(("python-six" ,python-six)
+       ("python-nose" ,python-nose)))
+    (home-page "https://github.com/JBKahn/rednose")
+    (synopsis "Colored output for Python nosetests")
+    (description "This package provides colored output for the
+@command{nosetests} command of the Python Nose unit test framework.")
+    (license license:bsd-3)))