summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-06-26 14:31:41 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-06-26 14:42:58 +0300
commit25e5daf1b1637880eab7421354d33492aa1a25b7 (patch)
tree71f5262d6f0184c88b05ef6ebb641acb3b8c9a7d /gnu
parente1a669b6d2ed79013720b462cb95cf2adb740c31 (diff)
downloadguix-25e5daf1b1637880eab7421354d33492aa1a25b7.tar.gz
gnu: ldc: Update skipped tests on i686-linux.
* gnu/packages/dlang.scm (ldc)[arguments]: Adjust custom
'disable-problematic-tests phase to skip fewer tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/dlang.scm22
1 files changed, 7 insertions, 15 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index f25c70a89b..76c71c43e2 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -298,30 +298,22 @@ bootstrapping more recent compilers written in D.")
                (substitute* "runtime/druntime/test/exceptions/Makefile"
                  ((".*TESTS\\+=rt_trap_exceptions_drt_gdb.*")
                   ""))
-               ;; The following tests fail on the supported 32 bit systems,
-               ;; which are not tested upstream.
+               ;; The following tests fail on some systems, not all of
+               ;; which are tested upstream.
                (with-directory-excursion "tests"
-                 (let ((system ,(or (%current-target-system)
-                                    (%current-system))))
-                   (when (or (string-prefix? "armhf" system )
-                             (string-prefix? "i686" system ))
+                 (cond
+                   (,(or (target-x86-32?)
+                         (target-arm32?))
                      (for-each delete-file
                                '("PGO/profile_rt_calls.d"
                                  "codegen/mangling.d"
-                                 "debuginfo/print_gdb.d"
-                                 "dynamiccompile/bind.d"
-                                 "dynamiccompile/bind_bool.d"
-                                 "dynamiccompile/bind_func_opt.d"
-                                 "dynamiccompile/bind_nested_opt.d"
-                                 "dynamiccompile/bind_opt.d"
-                                 "dynamiccompile/compiler_context.d"
-                                 "dynamiccompile/compiler_context_parallel.d"
                                  "instrument/xray_check_pipeline.d"
                                  "instrument/xray_link.d"
                                  "instrument/xray_simple_execution.d"
                                  "sanitizers/msan_noerror.d"
                                  "sanitizers/msan_uninitialized.d"
-                                 "d2/dmd-testsuite/runnable_cxx/cppa.d")))))))
+                                 "d2/dmd-testsuite/runnable_cxx/cppa.d")))
+                   (#t '())))))
            (add-before 'configure 'set-cc-and-cxx-to-use-clang
              ;; The tests require to be built with Clang; build everything
              ;; with it, for simplicity.