summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-21 17:15:13 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-21 17:24:31 +0200
commit25febeedc6457b8c064aa4045394b39efc46d22c (patch)
tree186e7bc13ff54fc15b8839b5dd5d9c5562dce806 /gnu
parent7eab5e7377de82666d41a8e58e3d9f7e116df5ff (diff)
downloadguix-25febeedc6457b8c064aa4045394b39efc46d22c.tar.gz
gnu: python-numpydoc: Update to 0.8.0.
* gnu/packages/python.scm (python-numpydoc): Update to 0.8.0.
[source](uri): Use PYPI-URI.
[source](snippet): Remove.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm17
1 files changed, 3 insertions, 14 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e47da91306..e574aec555 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3222,25 +3222,14 @@ that client code uses to construct the grammar directly in Python code.")
 (define-public python-numpydoc
   (package
     (name "python-numpydoc")
-    (version "0.5")
+    (version "0.8.0")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append
-             "https://pypi.python.org/packages/source/n/numpydoc/numpydoc-"
-             version ".tar.gz"))
+       (uri (pypi-uri "numpydoc" version))
        (sha256
         (base32
-         "0d4dnifaxkll50jx6czj05y8cb4ny60njd2wz299sj2jxfy51w4k"))
-       (modules '((guix build utils)))
-       (snippet
-        '(begin
-           ;; Drop a test requiring matplotlib, which we cannot add as an
-           ;; input since it would create a circular dependency: Extend the
-           ;; test for Python 3, where it is already dropped, to Python 2.
-           (substitute* "numpydoc/tests/test_plot_directive.py"
-             (("3") "2"))
-           #t))))
+         "1zazxg3m8j4fksv3f7v7vpf4bj9qb1vj3r326am0vdip141vzx31"))))
     (build-system python-build-system)
     (propagated-inputs
      `(("python-sphinx" ,python-sphinx)))