summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-05-06 21:41:52 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-05-07 09:23:06 +0200
commit3078c05eb2b514593ee34049eda49111ccbc3106 (patch)
tree3754883d9f467790e8a30dd8bb99c060352ce07c /gnu
parentd35a0f14528166cd0d76abab409e3d74c79dadd8 (diff)
downloadguix-3078c05eb2b514593ee34049eda49111ccbc3106.tar.gz
gnu: sbcl-iolib.grovel: Deprecate in favour of sbcl-cffi-grovel.
* gnu/packages/lisp-xyz.scm (sbcl-iolib.grovel): Deprecate since upstream has
  removed it; they are now using cffi-grovel instead.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm21
1 files changed, 1 insertions, 20 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index fc15bf40a9..4f406ded66 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5478,26 +5478,7 @@ and @code{kqueue(2)}), a pathname library and file-system utilities.")
     (synopsis "Base package for IOLib, a Common Lisp I/O library")))
 
 (define-public sbcl-iolib.grovel
-  (package
-    (inherit sbcl-iolib.asdf)
-    (name "sbcl-iolib.grovel")
-    (inputs
-     `(("iolib.asdf" ,sbcl-iolib.asdf)
-       ("iolib.conf" ,sbcl-iolib.conf)
-       ("iolib.base", sbcl-iolib.base)
-       ("cffi", sbcl-cffi)))
-    (arguments
-     '(#:asd-file "iolib.grovel.asd"
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'install-header
-           (lambda* (#:key outputs #:allow-other-keys)
-             ;; This header is required by sbcl-iolib.
-             (install-file "src/grovel/grovel-common.h"
-                           (string-append (assoc-ref outputs "out")
-                                          "/lib/sbcl"))
-             #t)))))
-    (synopsis "CFFI Groveller for IOLib, a Common Lisp I/O library")))
+  (deprecated-package "sbcl-iolib.grovel" sbcl-cffi-grovel))
 
 (define sbcl-iolib+syscalls
   (package