summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-12-24 00:35:32 +0100
committerLudovic Courtès <ludo@gnu.org>2022-12-24 00:45:47 +0100
commit3532fc6ba4d36ae055f11245a29fb6e8e54c545c (patch)
tree7abe793f10ed285406e5325bd22e2825b69f7aeb /gnu
parent69fc67b6bbd84bae2dfda1dcfc667946a368298a (diff)
downloadguix-3532fc6ba4d36ae055f11245a29fb6e8e54c545c.tar.gz
gnu: libtirpc-hurd: Fix cross-compilation.
Fixes a regression introduced in
517618b2401c2ab5861e63df60ae49918b94f727, whereby the "wrong"
'krb5-config' script would be picked.

* gnu/packages/onc-rpc.scm (libtirpc/hurd)[arguments]: Turn
 #:configure-flags into a gexp to refer to the right "mit-krb5".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/onc-rpc.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/onc-rpc.scm b/gnu/packages/onc-rpc.scm
index 4495622191..3928e80476 100644
--- a/gnu/packages/onc-rpc.scm
+++ b/gnu/packages/onc-rpc.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2017, 2018, 2022 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
 ;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -27,6 +27,7 @@
   #:use-module (guix licenses)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
@@ -84,9 +85,9 @@ IPv4 and IPv6.  ONC RPC is notably used by the network file system (NFS).")
      (substitute-keyword-arguments (package-arguments libtirpc)
        ((#:configure-flags flags ''())
         ;; When cross-building the target system's krb5-config should be used.
-        `(list (string-append "ac_cv_prog_KRB5_CONFIG="
-                              (assoc-ref %build-inputs "mit-krb5")
-                              "/bin/krb5-config")))))))
+        #~(list (string-append "ac_cv_prog_KRB5_CONFIG="
+                               #$(this-package-input "mit-krb5")
+                               "/bin/krb5-config")))))))
 
 (define libtirpc/fixed
   (package