summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2014-02-05 21:27:20 +0100
committerLudovic Courtès <ludo@gnu.org>2014-02-06 19:01:52 +0100
commit3600420e3e4bfc105e3d01474688ab10a7eb37a6 (patch)
tree424de805f9158d724daf89539217ef760e0d8478 /gnu
parentc6ebb77cb7c3e845ddc8f4fc13d9dad7f5cd3a28 (diff)
downloadguix-3600420e3e4bfc105e3d01474688ab10a7eb37a6.tar.gz
gnu: Add Glade.
* gnu/packages/gnome.scm (glade): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 90683f3635..5d17b019fd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -496,3 +496,30 @@ the API")
 additional GDK objects which support OpenGL rendering in GTK+ and GtkWidget
 API add-ons to make GTK+ widgets OpenGL-capable.")
     (license lgpl2.1+)))
+
+(define-public glade3
+  (package
+    (name "glade")
+    (version "3.8.4")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnome/sources/" name "/"
+                          (substring version 0 (string-rindex version #\.)) "/"
+                          name "3-" version ".tar.xz"))
+              (sha256
+               (base32 "021xgq2l18w3rvwms9aq2idm0fk66vwb4f777gs0qh3ap5shgbn7"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("gtk+" ,gtk+-2)
+       ("libxml2" ,libxml2)))
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("python" ,python)
+       ("pkg-config" ,pkg-config)))
+    (home-page "https://glade.gnome.org")
+    (synopsis "GTK+ rapid application development tool")
+    (description "Glade is a rapid application development (RAD) tool to
+enable quick & easy development of user interfaces for the GTK+ toolkit and
+the GNOME desktop environment.")
+    (license lgpl2.0+)))