summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-04 22:47:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:28 +0200
commit376059576e02fbc312816410dcefddfffae7944d (patch)
treeef0b45b880c926fbe11491677ca18e0b20b578b8 /gnu
parent1a8e352119f1d5a87b43261cfb99841f1c238aba (diff)
downloadguix-376059576e02fbc312816410dcefddfffae7944d.tar.gz
gnu: texlive-latex-etoc -> texlive-etoc.
* gnu/packages/tex.scm (texlive-etoc): New variable.
(texlive-latex-etoc): Deprecate variable.
* gnu/packages/maths.scm (hypre): Apply renaming.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/tex.scm54
2 files changed, 31 insertions, 25 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index cd9b0fc325..e829c30eb8 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5786,6 +5786,7 @@ set.")
                                      texlive-cm
                                      texlive-courier
                                      texlive-enumitem
+                                     texlive-etoc
                                      texlive-etoolbox
                                      texlive-fancyhdr
                                      texlive-fancyvrb
@@ -5799,7 +5800,6 @@ set.")
                                      texlive-generic-listofitems
                                      texlive-latex-cmap
                                      texlive-latex-colortbl
-                                     texlive-latex-etoc
                                      texlive-latex-float
                                      texlive-latex-fncychap
                                      texlive-latex-framed
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b07fe853d5..ea1b13f2b0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4935,36 +4935,42 @@ also provided.")
 
 (define-deprecated-package texlive-latex-eqparbox texlive-eqparbox)
 
-(define-public texlive-latex-etoc
+(define-public texlive-etoc
   (package
-    (inherit (simple-texlive-package
-              "texlive-latex-etoc"
-              '("/doc/latex/etoc/README.md"
-                "/doc/latex/etoc/etoc.pdf"
-                "/tex/latex/etoc/")
-              (base32
-               "0198cn75m1y8ggbfv1qlnif0d9275f6mxqsansyqw4np0rv6q9sv")
-              #:trivial? #t))
-    (home-page "https://www.ctan.org/pkg/etoc")
-    (synopsis "Completely customisable TOCs")
+    (name "texlive-etoc")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/etoc/"
+                   "source/latex/etoc/"
+                   "tex/latex/etoc/")
+             (base32
+              "04vjfn4jadxbc38r08r9pwvpj7szvk88hiav35iqhl3p78xri7z4")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/etoc")
+    (synopsis "Customisable table of contents")
     (description
-     "This package gives the user complete control of how the entries of
-the table of contents should be constituted from the name, number, and page
-number of each sectioning unit.  The layout is controlled by the definition
-of ‘line styles’ for each sectioning level used in the document.
+     "This package gives the user complete control of how the entries of the
+table of contents should be constituted from the name, number, and page number
+of each sectioning unit.  The layout is controlled by the definition of line
+styles for each sectioning level used in the document.
 
 The package provides its own custom line styles (which may be used as
-examples), and continues to support the standard formatting inherited from
-the LaTeX document classes, but the package can also allow the user to
-delegate the details to packages dealing with list making environments (such
-as enumitem).  The package’s default global style typesets tables of contents
-in a multi-column format, with either a standard heading, or a ruled title
+examples), and continues to support the standard formatting inherited from the
+LaTeX document classes, but the package can also allow the user to delegate
+the details to packages dealing with list making environments (such as
+@code{enumitem}).  The package's default global style typesets tables of
+contents in a multi-column format, with either a standard heading, or a ruled
+title
 (optionally with a frame around the table).
 
-The @code{\\tableofcontents} command may be used arbitrarily many times in
-the same document, while @code{\\localtableofcontents} provides a ‘local’
-table of contents.")
-    (license license:lppl1.3c+)))
+The @code{\\tableofcontents} command may be used arbitrarily many times in the
+same document, while @code{\\localtableofcontents} provides a local table of
+contents.")
+    (license license:lppl1.3c)))
+
+(define-deprecated-package texlive-latex-etoc texlive-etoc)
 
 (define-public texlive-latex-expdlist
   (package