summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorKaelyn Takata <kaelyn.alexi@protonmail.com>2023-01-11 20:26:17 +0000
committer宋文武 <iyzsong@member.fsf.org>2023-01-12 14:25:50 +0800
commit4171b018083068376bb468263429a8af6f701364 (patch)
treeb7ea3ac2625d366e9e7d65f09ce2c9ca6cd1f61a /gnu
parent740eb6d7a9da9d26003d27b4f80388abd8ed5521 (diff)
downloadguix-4171b018083068376bb468263429a8af6f701364.tar.gz
gnu: Remove xfce4-embed-plugin.
The last release of this plugin appears to be 2015, and the package no
longer builds as it depends on libxfce4ui-1 which was removed when gtk+-2
support was dropped in 2019.

* gnu/packages/xfce.scm (xfce4-embed-plugin): Delete variable.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xfce.scm32
1 files changed, 0 insertions, 32 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 9692d9edc0..f8409c4e0f 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1590,38 +1590,6 @@ governor and frequencies supported and used by your system.")
 performance (bytes transferred per second).")
     (license gpl2+)))
 
-(define-public xfce4-embed-plugin
-  (package
-   (name "xfce4-embed-plugin")
-   (version "1.6.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://archive.xfce.org/src/panel-plugins/"
-                                  "xfce4-embed-plugin/"
-                                  (version-major+minor version)
-                                  "/xfce4-embed-plugin-" version ".tar.bz2"))
-              (sha256
-               (base32
-                "0a72kqsjjh45swimqlpyrahdnplp0383v0i4phr4n6g8c1ixyry7"))))
-    (build-system gnu-build-system)
-    (native-inputs
-     (list intltool pkg-config))
-    (inputs
-     (list libxfce4ui xfce4-panel gtk+-2))
-    (home-page
-     "https://goodies.xfce.org/projects/panel-plugins/xfce4-embed-plugin")
-    (synopsis "Embed arbitrary applications inside the Xfce panel")
-    (description "This plugin enables the embedding of arbitrary
-application windows into the Xfce panel.  The window is resized into
-the panel space available, and the associated program can be
-automatically launched if it is not open.
-
-Example uses include embedding an instant messaging buddy list, a mail
-client's new mail ticker, a simple media application, or a fancy clock
-or timer.  Combining with Xfce's ability to auto-hide panels can make
-this very convenient.")
-    (license gpl2+)))
-
 (define-public xfce4-fsguard-plugin
   (package
    (name "xfce4-fsguard-plugin")