summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-07 11:35:32 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-07 11:51:58 -0400
commit47f0b3ad1491e7069323d361d1c84da495ed15ce (patch)
treef5128283b2a34824a16f60a9c03daac842c6eb12 /gnu
parent6428f854f9d8e4b844589a5c5bb16df583a087ec (diff)
downloadguix-47f0b3ad1491e7069323d361d1c84da495ed15ce.tar.gz
gnu: pitivi: Propagate librsvg.
Fixes <https://issues.guix.gnu.org/56288>.

* gnu/packages/video.scm (pitivi)[native-inputs]: Use new style, relocate
before inputs.
[inputs]: Add bash-minimal, for wrap-program.  Move librsvg to...
[propagated-inputs]: ... this new field.
[phases]{wrap-other-dependencies}: Use search-input-file to find output
binary.

Reported-by: Christian Miller <miller.christian@proton.me>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm35
1 files changed, 18 insertions, 17 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 40c31cdaec..3c9247ef17 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4340,8 +4340,14 @@ tools for styling them, including a built-in real-time video preview.")
         (sha256
          (base32 "08x2fs2bak1fbmkvjijgx1dsawispv91bpv5j5gkqbv5dfgf7wah"))))
      (build-system meson-build-system)
+     (native-inputs
+      (list gettext-minimal
+            `(,glib "bin")
+            itstool
+            pkg-config))
      (inputs
-      (list glib
+      (list bash-minimal
+            glib
             gst-editing-services
             gstreamer
             gst-plugins-base
@@ -4353,7 +4359,6 @@ tools for styling them, including a built-in real-time video preview.")
             gst-libav
             gsound
             gtk+
-            librsvg
             libpeas
             libnotify
             pango
@@ -4363,27 +4368,23 @@ tools for styling them, including a built-in real-time video preview.")
             python-matplotlib
             python-pycairo
             python-pygobject))
-    (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("glib:bin" ,glib "bin")
-       ("itstool" ,itstool)
-       ("pkg-config" ,pkg-config)))
+     ;; Propagate librsvg so that is is registered in GDK_PIXBUF_MODULE_FILE,
+     ;; otherwise pitivi fails to launch.
+     (propagated-inputs (list librsvg))
      (arguments
       `(#:glib-or-gtk? #t
         #:phases
         (modify-phases %standard-phases
           (add-after 'glib-or-gtk-wrap 'wrap-other-dependencies
             (lambda* (#:key outputs #:allow-other-keys)
-              (let ((prog (string-append (assoc-ref outputs "out")
-                                         "/bin/pitivi")))
-                (wrap-program prog
-                  `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))
-                  `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))
-                  ;; We've only added inputs for what Pitivi deems either
-                  ;; necessary or optional.  Let the user's packages take
-                  ;; precedence in case they have e.g. the full gst-plugins-bad.
-                  `("GST_PLUGIN_SYSTEM_PATH" suffix
-                    (,(getenv "GST_PLUGIN_SYSTEM_PATH"))))))))))
+              (wrap-program (search-input-file outputs "bin/pitivi")
+                `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))
+                `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))
+                ;; We've only added inputs for what Pitivi deems either
+                ;; necessary or optional.  Let the user's packages take
+                ;; precedence in case they have e.g. the full gst-plugins-bad.
+                `("GST_PLUGIN_SYSTEM_PATH" suffix
+                  (,(getenv "GST_PLUGIN_SYSTEM_PATH")))))))))
      (home-page "http://www.pitivi.org")
      (synopsis "Video editor based on GStreamer Editing Services")
      (description "Pitivi is a video editor built upon the GStreamer Editing