summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-19 23:05:21 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-19 23:15:50 +0100
commit4fd540b7f0fe672f7509e29157620bb22fd2e883 (patch)
tree4b75d883c33697a55f60edf10febd87e570d2947 /gnu
parentfa275717d8f39abeac272ac2510912e40ee5ffb0 (diff)
downloadguix-4fd540b7f0fe672f7509e29157620bb22fd2e883.tar.gz
gnu: Add emacs-no-x.
* gnu/packages/emacs.scm (emacs-no-x): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 96c6148ce5..021bfb3199 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -114,6 +114,23 @@ large Lisp programs.  It has full Unicode support for nearly all human
 languages.")
     (license license:gpl3+)))
 
+(define-public emacs-no-x
+  ;; This is the version that you should use as an input to packages that just
+  ;; need to byte-compile .el files.
+  (package (inherit emacs)
+    (location (source-properties->location (current-source-location)))
+    (name "emacs-no-x")
+    (synopsis "The extensible, customizable, self-documenting text
+editor (console only)")
+    (build-system gnu-build-system)
+    (inputs (fold alist-delete
+                  (package-inputs emacs)
+                  '("libx11" "gtk+" "libxft" "libtiff" "giflib" "libjpeg"
+                    "libpng" "libxpm" "libice" "libsm"
+
+                    ;; D-Bus depends on libx11, so remove it as well.
+                    "dbus")))))
+
 (define-public emacs-no-x-toolkit
   (package (inherit emacs)
     (location (source-properties->location (current-source-location)))