summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEkaitz Zarraga <ekaitz@elenq.tech>2020-12-05 23:51:30 +0000
committerMarius Bakke <marius@gnu.org>2020-12-06 22:28:10 +0100
commit50c24bbd4f2d2e48d5eda9ac540a6dc15e7cf6a3 (patch)
tree98f6835a8292daecf164148e81d72acb1ccf5132 /gnu
parentbca3220b60031a746bc7a6f96cfb3aa25c604792 (diff)
downloadguix-50c24bbd4f2d2e48d5eda9ac540a6dc15e7cf6a3.tar.gz
gnu: freecad: Fix compilation flags.
* gnu/packages/engineering.scm (freecad)[arguments]: Set correct
search paths in compilation flags.  Fixes <https://bugs.gnu.org/43448>.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/engineering.scm24
1 files changed, 22 insertions, 2 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 558541dd5a..5a8977c940 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2496,8 +2496,28 @@ full programmatic control over your models.")
        #:configure-flags
        (list
         "-DBUILD_QT5=ON"
-        (string-append "-DCMAKE_INSTALL_LIBDIR="
-                       (assoc-ref %outputs "out") "/lib"))
+        (string-append "-DCMAKE_INSTALL_LIBDIR=" (assoc-ref %outputs "out") "/lib")
+
+        (string-append "-DPYSIDE2UICBINARY="
+                       (assoc-ref %build-inputs "python-pyside-2-tools")
+                       "/bin/uic")
+        (string-append "-DPYSIDE2RCCBINARY="
+                       (assoc-ref %build-inputs "python-pyside-2-tools")
+                       "/bin/rcc")
+
+        "-DPYSIDE_LIBRARY=PySide2::pyside2"
+        (string-append
+         "-DPYSIDE_INCLUDE_DIR="
+         (assoc-ref %build-inputs "python-pyside-2") "/include;"
+         (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2;"
+         (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtCore;"
+         (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtWidgets;"
+         (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtGui;")
+
+        "-DSHIBOKEN_LIBRARY=Shiboken2::libshiboken"
+        (string-append "-DSHIBOKEN_INCLUDE_DIR="
+                       (assoc-ref %build-inputs "python-shiboken-2")
+                       "/include/shiboken2"))
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'restore-pythonpath