summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-12-31 09:25:45 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-01-28 00:08:32 +1000
commit5799aadde41ea576c158ddf027ea8d16f47c91ac (patch)
tree661b1e36e1915f0f248d0f67ded948cbc92ae7c3 /gnu
parent3b44bcdfcdb161dd1109635c449034a0a0f9e7e9 (diff)
downloadguix-5799aadde41ea576c158ddf027ea8d16f47c91ac.tar.gz
gnu: Add ruby-domain-name.
* gnu/packages/ruby.scm (ruby-domain-name): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 181c279564..ed1bc6975f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3334,6 +3334,46 @@ support to both Ruby and JRuby.  It uses @code{unf_ext} on CRuby and
     (home-page "https://github.com/knu/ruby-unf")
     (license license:bsd-2)))
 
+(define-public ruby-domain-name
+  (package
+    (name "ruby-domain-name")
+    (version "0.5.25")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "domain_name" version))
+       (sha256
+        (base32
+         "16qvfrmcwlzz073aas55mpw2nhyhjcn96s524w0g1wlml242hjav"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'fix-versions
+           (lambda _
+             ;; Fix NameError that appears to already be fixed upstream.
+             (substitute* "Rakefile"
+               (("DomainName::VERSION")
+                "Bundler::GemHelper.gemspec.version"))
+             ;; Loosen unnecessarily strict test-unit version specification.
+             (substitute* "domain_name.gemspec"
+               (("<test-unit>, \\[\\\"~> 2.5.5") "<test-unit>, [\">0"))
+             #t)))))
+    (propagated-inputs
+     `(("ruby-unf" ,ruby-unf)))
+    (native-inputs
+     `(("ruby-shoulda" ,ruby-shoulda)
+       ("bundler" ,bundler)
+       ("ruby-test-unit" ,ruby-test-unit)))
+    (synopsis "Domain name manipulation library")
+    (description
+     "@code{domain_name} is a Domain name manipulation library.  It parses a
+domain name ready for extracting the registered domain and TLD (Top Level
+Domain).  It can also be used for cookie domain validation based on the Public
+Suffix List.")
+    (home-page "https://github.com/knu/ruby-domain_name")
+    (license license:bsd-2)))
+
 (define-public ruby-ansi
   (package
     (name "ruby-ansi")