summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authoraecepoglu <aecepoglu@fastmail.fm>2021-05-14 19:18:48 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-11 11:08:17 +0300
commit5c3489a3f7f33293dfdaff23374d93a01c838968 (patch)
tree009b1ddd47cffd28baaf65a921ad912174b1a56b /gnu
parent9373e358a52b656ec838e84b059a6ec7851d2cc1 (diff)
downloadguix-5c3489a3f7f33293dfdaff23374d93a01c838968.tar.gz
gnu: Add parinfer-rust.
* gnu/packages/text-editors.scm (parinfer-rust): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/text-editors.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 2f9708ad1b..965ed6b9e7 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -251,6 +251,40 @@ competitive (as in keystroke count) with Vim.")
 Rust.")
     (license license:unlicense)))
 
+(define-public parinfer-rust
+  (package
+    (name "parinfer-rust")
+    (version "0.4.3")
+    (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/eraserhd/parinfer-rust")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "0hj5in5h7pj72m4ag80ing513fh65q8xlsf341qzm3vmxm3y3jgd"))
+       (file-name (git-file-name name version))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-getopts" ,rust-getopts-0.2)
+        ("rust-libc" ,rust-libc-0.2)
+        ("rust-emacs" ,rust-emacs-0.11)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-serde-derive" ,rust-serde-derive-1)
+        ("rust-unicode-segmentation" ,rust-unicode-segmentation-1)
+        ("rust-unicode-width" ,rust-unicode-width-0.1))))
+    (inputs
+     `(("clang" ,clang)))
+    (home-page "https://github.com/justinbarclay/parinfer-rust")
+    (synopsis "Infer parantheses for Clojure, Lisp and Scheme")
+    (description
+     "Parinfer is a plugin for Kakoune, Vim, Neovim and Emacs that infers
+paretheses and indentation.  This library can be called from other editors that
+can load dynamic libraries.")
+    (license license:expat)))
+
 (define-public joe
   (package
     (name "joe")