summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-12-29 07:48:10 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-12-29 07:52:19 +0100
commit5f1c94986668d413b63730036b2366b8f5127c77 (patch)
tree667531cc8c647671e34470290dade51e44126c39 /gnu
parentc1ff0f2fedfaa93a225d2060731c2354b839e545 (diff)
downloadguix-5f1c94986668d413b63730036b2366b8f5127c77.tar.gz
gnu: tuxguitar: Use "modify-phases" syntax.
* gnu/packages/music.scm (tuxguitar)[arguments]: Use "modify-phases"
  syntax.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 3787576aea..dcda09a264 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -701,17 +701,17 @@ is subjective.")
        #:tests? #f ;no "check" target
        #:parallel-build? #f ;not supported
        #:phases
-       (alist-cons-before
-        'build 'enter-dir-set-path-and-pass-ldflags
-        (lambda* (#:key inputs #:allow-other-keys)
-          (chdir "TuxGuitar")
-          (substitute* "GNUmakefile"
-            (("PROPERTIES\\?=")
-             (string-append "PROPERTIES?= -Dswt.library.path="
-                            (assoc-ref inputs "swt") "/lib"))
-            (("\\$\\(GCJ\\) -o") "$(GCJ) $(LDFLAGS) -o"))
-          #t)
-        (alist-delete 'configure %standard-phases))))
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (add-before 'build 'enter-dir-and-set-flags
+          (lambda* (#:key inputs #:allow-other-keys)
+            (chdir "TuxGuitar")
+            (substitute* "GNUmakefile"
+              (("PROPERTIES\\?=")
+               (string-append "PROPERTIES?= -Dswt.library.path="
+                              (assoc-ref inputs "swt") "/lib"))
+              (("\\$\\(GCJ\\) -o") "$(GCJ) $(LDFLAGS) -o"))
+            #t)))))
     (inputs
      `(("swt" ,swt)))
     (native-inputs