summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-05-19 13:50:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-05-19 20:05:58 +0300
commit64d1d2b271babed83afaabf034dac67bbae3a364 (patch)
tree5c91b42e26aa25315ffeba3d8b1a9cb22cf35f38 /gnu
parent75ac5c5281cf032f947847532718e73afdbb9167 (diff)
downloadguix-64d1d2b271babed83afaabf034dac67bbae3a364.tar.gz
gnu: Add python-mujson.
* gnu/packages/python-xyz.scm (python-mujson): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c26a766d64..8532de9873 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19895,3 +19895,21 @@ allows you, from Python code, to “fix” invalid (X)HTML markup.")
 
 (define-public python2-pytidylib
   (package-with-python2 python-pytidylib))
+
+(define-public python-mujson
+  (package
+    (name "python-mujson")
+    (version "1.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "mujson" version))
+        (sha256
+         (base32
+          "0wbj6r8yzsdx2b0kbldlkznr1a9nn33za2q9x3g0hbg420dwzn97"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/mattgiles/mujson")
+    (synopsis "Use the fastest JSON functions available at import time")
+    (description "This packages selects the fastest JSON functions available
+at import time.")
+    (license license:expat)))