summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-07 14:41:09 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-07 14:51:06 +0100
commit68044c1634ff967e2206b46534d9739f4af1db65 (patch)
tree392f6be8536c9311a323f69044a0f7df73ed28e2 /gnu
parent18b46c5637db81ab5720363d7b64c1ef50633081 (diff)
downloadguix-68044c1634ff967e2206b46534d9739f4af1db65.tar.gz
gnu: Add perl-authen-dechpwd.
* gnu/packages/perl.scm (perl-authen-dechpwd): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index aaf3f256ff..beb3567ff0 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -364,6 +364,37 @@ of general interest as follows:
 @end itemize")
     (license (package-license perl))))
 
+(define-public perl-authen-dechpwd
+  (package
+    (name "perl-authen-dechpwd")
+    (version "2.007")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append
+            "mirror://cpan/authors/id/Z/ZE/ZEFRAM/Authen-DecHpwd-"
+            version ".tar.gz"))
+      (sha256
+       (base32
+        "0xzind7zr2prjq3zbs2j18snfpshd4xrd7igv4kp67xl0axr6fpl"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-module-build" ,perl-module-build)
+       ("perl-test-pod" ,perl-test-pod)
+       ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+    (propagated-inputs
+     `(("perl-data-integer" ,perl-data-integer)
+       ("perl-digest-crc" ,perl-digest-crc)
+       ("perl-scalar-string" ,perl-scalar-string)))
+    (home-page "https://metacpan.org/release/Authen-DecHpwd")
+    (synopsis "DEC VMS password hashing")
+    (description "@code{Authen::DecHpwd} implements the
+SYS$HASH_PASSWORD password hashing function from VMS (also known as
+LGI$HPWD) and some associated VMS username and password handling
+functions.  The password hashing function is implemented in XS with a
+pure Perl backup version for systems that cannot handle XS.")
+    (license gpl2+)))
+
 (define-public perl-autovivification
   (package
     (name "perl-autovivification")