summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-12-29 07:48:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-12-29 07:52:19 +0100
commit6da2e99e2e3465f5853b65e564a286cb7c12964c (patch)
tree21b401fff933f631e1d0278a73653026eabcb9ba /gnu
parent5f1c94986668d413b63730036b2366b8f5127c77 (diff)
downloadguix-6da2e99e2e3465f5853b65e564a286cb7c12964c.tar.gz
gnu: tuxguitar: Set missing GCJFLAGS.
* gnu/packages/music.scm (tuxguitar)[arguments]: Set compiler flags
  "-fsource=1.4" and "-fPIC".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index dcda09a264..264fcd9d0f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -707,6 +707,8 @@ is subjective.")
           (lambda* (#:key inputs #:allow-other-keys)
             (chdir "TuxGuitar")
             (substitute* "GNUmakefile"
+              (("GCJFLAGS\\+=(.*)" _ rest)
+               (string-append "GCJFLAGS=-fsource=1.4 -fPIC " rest))
               (("PROPERTIES\\?=")
                (string-append "PROPERTIES?= -Dswt.library.path="
                               (assoc-ref inputs "swt") "/lib"))