summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRostislav Svoboda <Rostislav.Svoboda@gmail.com>2023-03-08 16:15:31 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-08 16:15:31 +0100
commit71f315ceaee924f32f3449e02642ab3e5d1c00a9 (patch)
tree33e38d18ff6032da675f746ac99131f137206f0d /gnu
parentca0a4a9dc27119538ea9b05fa886b0f728549796 (diff)
downloadguix-71f315ceaee924f32f3449e02642ab3e5d1c00a9.tar.gz
gnu: Add emacs-ace-jump-helm-line.
* gnu/packages/emacs-xyz.scm (emacs-ace-jump-helm-line): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0665fc3c39..ac448c6480 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -287,6 +287,29 @@
        "AC Ispell is an Ispell and Aspell completion source for Auto Complete.")
       (license license:gpl3+))))
 
+(define-public emacs-ace-jump-helm-line
+  (let ((commit "1483055255df3f8ae349f7520f05b1e43ea3ed37")
+        (revision "0"))
+    (package
+      (name "emacs-ace-jump-helm-line")
+      (version (git-version "0.5.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/cute-jumper/ace-jump-helm-line")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "191a2g1if1jliikbxkpwmvlp4v1sp541j71xrlymili8ygm0idq5"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-avy emacs-helm))
+      (home-page "https://github.com/cute-jumper/ace-jump-helm-line")
+      (synopsis "Ace-jump to a candidate in Helm window")
+      (description
+       "This packages allows to use Ace jump to a candidate in Helm window.")
+      (license license:gpl3+))))
+
 (define-public emacs-cfrs
   (package
     (name "emacs-cfrs")