summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-04-10 20:48:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-04-10 20:49:34 +0300
commit72abf9b9b82d2f5f34b7d22b7aae6f2398336a93 (patch)
treebe4f5832b4942ce48ee69887364c79cf810b48a2 /gnu
parent96a132809f0196d6a08f6c5c6900846d9859beb2 (diff)
downloadguix-72abf9b9b82d2f5f34b7d22b7aae6f2398336a93.tar.gz
gnu: jq: Only build with valgrind on supported systems.
* gnu/packages/web.scm (jq)[native-inputs]: Only include valgrind on
systems which it supports.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 134cac1c9a..1587734ee6 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4886,10 +4886,14 @@ It uses the uwsgi protocol for all the networking/interprocess communications.")
     (inputs
      (list oniguruma))
     (native-inputs
-     (list ;; TODO fix gems to generate documentation
-           ;;("ruby" ,ruby)
-           ;;("bundler" ,bundler)
-           valgrind))
+     (append
+       ;; TODO: fix gems to generate documentation
+       ;(list ruby bundler)
+       '()
+       (if (member (%current-system)
+                   (package-supported-systems valgrind))
+         (list valgrind)
+         '())))
     (build-system gnu-build-system)
     (home-page "https://stedolan.github.io/jq/")
     (synopsis "Command-line JSON processor")