summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-04-13 21:22:44 +0200
committerLudovic Courtès <ludo@gnu.org>2021-04-16 23:25:23 +0200
commit7a6625e83f68f6408ff0a82b12e7a95c6b0cc096 (patch)
tree9f467ec017aa5b9d10b8a6a9f016ef5c7921d8ab /gnu
parentc68070e4eefd25118b368bd7af872f65ab739fc7 (diff)
downloadguix-7a6625e83f68f6408ff0a82b12e7a95c6b0cc096.tar.gz
gnu: guile-git: Switch to 'git-fetch'.
* gnu/packages/guile.scm (guile-git)[source]: Use ‘git-fetch’ instead of
‘url-fetch’.
[native-inputs]: Add autoconf, automake, and texinfo.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 813639ef7e..1616991cca 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -779,18 +779,22 @@ type system, elevating types to first-class status.")
     (version "0.5.0")
     (home-page "https://gitlab.com/guile-git/guile-git.git")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://gitlab.com/guile-git/guile-git/uploads/"
-                                  "30be542d90619ca844dd3a3ed2e13808/guile-git-"
-                                  version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1j39c1cq9cbwir90mpnbdijpbwh7wkxampgl2r177bv8bfw6y203"))))
+                "1hqw3jy81cnsgybsbnfvwvhv1bajwq662hikkrr6dcgky6yspsxx"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags '("GUILE_AUTO_COMPILE=0")))     ; to prevent guild warnings
     (native-inputs
      `(("pkg-config" ,pkg-config)
+       ("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("texinfo" ,texinfo)
        ("guile" ,guile-3.0)
        ("guile-bytestructures" ,guile-bytestructures)))
     (inputs