summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-17 16:36:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-22 18:54:59 +0200
commit7b46532779ddc6b01f99989be0eda91149809ce4 (patch)
tree809136b9ba223d55ae0c71ca474c400ac8b0e85d /gnu
parentd4b83651d1331ebe5327d0d448567f3084bdd8b5 (diff)
downloadguix-7b46532779ddc6b01f99989be0eda91149809ce4.tar.gz
gnu: Add r-deseq.
* gnu/packages/bioinformatics.scm (r-deseq): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a372b163cf..55c076ca1b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9021,6 +9021,37 @@ standalone, be utilized in other packages, or be wrapped up in higher-level
 classes.")
     (license license:gpl2+)))
 
+(define-public r-deseq
+  (package
+    (name "r-deseq")
+    (version "1.28.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "DESeq" version))
+       (sha256
+        (base32
+         "0j3dgcxd64m9qknmlcbdzvg4xhp981xd6nbwsvnqjfn6yypslgyw"))))
+    (properties `((upstream-name . "DESeq")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biobase" ,r-biobase)
+       ("r-biocgenerics" ,r-biocgenerics)
+       ("r-genefilter" ,r-genefilter)
+       ("r-geneplotter" ,r-geneplotter)
+       ("r-lattice" ,r-lattice)
+       ("r-locfit" ,r-locfit)
+       ("r-mass" ,r-mass)
+       ("r-rcolorbrewer" ,r-rcolorbrewer)))
+    (home-page "http://www-huber.embl.de/users/anders/DESeq")
+    (synopsis "Differential gene expression analysis")
+    (description
+     "This package provides tools for estimating variance-mean dependence in
+count data from high-throughput genetic sequencing assays and for testing for
+differential expression based on a model using the negative binomial
+distribution.")
+    (license license:gpl3+)))
+
 (define htslib-for-sambamba
   (let ((commit "2f3c3ea7b301f9b45737a793c0b2dcf0240e5ee5"))
     (package