summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-07 17:06:39 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-10 23:05:25 +0100
commit7bfb7a596493346ca2c2ba993e871e92537c2956 (patch)
treed0e3859b2874480293f35b078a1cd488f5f70845 /gnu
parentd930b0261ca1479505109332db28b0e3df452848 (diff)
downloadguix-7bfb7a596493346ca2c2ba993e871e92537c2956.tar.gz
gnu: sdl2: Remove obsolete workaround.
* gnu/packages/sdl.scm (sdl2)[arguments]: Remove #:make-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/sdl.scm9
1 files changed, 0 insertions, 9 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 81393bf1a3..8ac9213db3 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -130,15 +130,6 @@ joystick, and graphics hardware.")
        ((#:configure-flags flags)
         `(append '("--disable-wayland-shared" "--enable-video-kmsdrm"
                    "--disable-kmsdrm-shared")
-                 ,flags))
-       ((#:make-flags flags ''())
-        ;; Add the Fcitx header files to GCCs "system header" search path
-        ;; in order to suppress compiler warnings induced by those:
-        ;;   .../include/fcitx-utils/utarray.h:178:9: error: ISO C90 forbids
-        ;;   mixed declarations and code [-Werror=declaration-after-statement]
-        `(append (list (string-append "C_INCLUDE_PATH="
-                                      (assoc-ref %build-inputs "fcitx")
-                                      "/include"))
                  ,flags))))
     (inputs
      ;; SDL2 needs to be built with ibus support otherwise some systems