summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:10:58 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:53 +0200
commit7ecc85525491986256af62febe3d154ebec9bc05 (patch)
tree88bed238306c7c8f616518cc0dc2944c6e010e5a /gnu
parent205457f814a9fe3e997777acb699d611472288d2 (diff)
downloadguix-7ecc85525491986256af62febe3d154ebec9bc05.tar.gz
gnu: Add elm-html.
* gnu/packages/elm.scm (elm-html): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/elm.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index c2ccd6c557..98b60c48f7 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -179,3 +179,22 @@ core libraries for HTML and SVG.  You should almost certainly use those
 higher-level libraries directly.")
     (properties '((upstream-name . "elm/virtual-dom")))
     (license license:bsd-3)))
+
+(define-public elm-html
+  (package
+    (name "elm-html")
+    (version "1.0.0")
+    (source
+     (elm-package-origin
+      "elm/html"
+      version
+      (base32 "15k1679ja57vvlpinpv06znmrxy09lbhzfkzdc89i01qa8c4gb4a")))
+    (build-system elm-build-system)
+    (propagated-inputs
+     (list elm-virtual-dom
+           elm-json
+           elm-core))
+    (home-page "https://package.elm-lang.org/packages/elm/html/1.0.0")
+    (synopsis "Fast HTML, rendered with virtual DOM diffing")
+    (description "This package provides Elm's HTML rendering library.")
+    (license license:bsd-3)))