summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorL p R n d n <guix@lprndn.info>2019-08-19 15:51:42 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-01 23:02:22 +0200
commit8c6cfdd766beb2b4cdbb2bb2ff209e33b5d76c19 (patch)
tree50b76c5d4543bc1c518630cf5fd642eb474838f8 /gnu
parentd4902f9a84e9495d1c603a5556787f0ec381b87f (diff)
downloadguix-8c6cfdd766beb2b4cdbb2bb2ff209e33b5d76c19.tar.gz
gnu: xfce4-pulseaudio-plugin: Update to 0.4.2.
* gnu/packages/xfce.scm (xfce4-pulseaudio-plugin): Update to 0.4.2.
[arguments] Add augment-cflags phase.
[native-inputs] Add dbus and dbus-glib.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xfce.scm21
1 files changed, 18 insertions, 3 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index cad3f7583b..1256578b1b 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -390,7 +390,7 @@ matching them against regular expressions.")
 (define-public xfce4-pulseaudio-plugin
   (package
     (name "xfce4-pulseaudio-plugin")
-    (version "0.4.1")
+    (version "0.4.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/panel-plugins/"
@@ -398,11 +398,26 @@ matching them against regular expressions.")
                                   name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "1w29y0a066y8as12xrkbfqcn7dpdsvx97idzw7028gmcvca87a3c"))))
+                "0851b0vs5xmy3cq899khcghmkqwvh9rnzwavi17msrsq4jyaxs2a"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       ;; For dbus/dbus-glib.h in pulseaudio-config.h
+       (modify-phases %standard-phases
+         (add-after 'set-paths 'augment-cflags
+           (lambda* (#:key inputs #:allow-other-keys)
+             (setenv "C_INCLUDE_PATH"
+                     (string-append (assoc-ref inputs "dbus-glib")
+                                    "/include/dbus-1.0" ":"
+                                    (assoc-ref inputs "dbus")
+                                    "/include/dbus-1.0" ":"
+                                    (getenv "C_INCLUDE_PATH")))
+             #t)))))
     (native-inputs
      `(("intltool" ,intltool)
-       ("pkg-config" ,pkg-config)))
+       ("pkg-config" ,pkg-config)
+       ("dbus-glib" ,dbus-glib)
+       ("dbus" ,dbus)))
     (inputs
      `(("exo" ,exo)
        ("libnotify" ,libnotify)