summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:26:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:37:59 +0200
commit8d4311bb8e0e7ae68f0182bf232f598ebe2835e5 (patch)
treee5d962fc69035572f60798ab903b0c2d05bfe67a /gnu
parent96ae9822c4c641587ea151e6a58eddbdb6e66590 (diff)
downloadguix-8d4311bb8e0e7ae68f0182bf232f598ebe2835e5.tar.gz
gnu: r-vsn: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-vsn): Move from here...
* gnu/packages/bioconductor.scm (r-vsn): ...to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm36
-rw-r--r--gnu/packages/bioinformatics.scm36
2 files changed, 36 insertions, 36 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 9faf7021da..a631143102 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3746,6 +3746,42 @@ dependencies between GO terms can be implemented and applied.")
 coding changes and predict coding outcomes.")
     (license license:artistic2.0)))
 
+(define-public r-vsn
+  (package
+    (name "r-vsn")
+    (version "3.58.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "vsn" version))
+       (sha256
+        (base32
+         "0dfrfflidpnphwyqzmmfiz9blfqv6qa09xlwgfabhpfsf3ml2rlb"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-affy" ,r-affy)
+       ("r-biobase" ,r-biobase)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-lattice" ,r-lattice)
+       ("r-limma" ,r-limma)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr))) ; for vignettes
+    (home-page "https://bioconductor.org/packages/release/bioc/html/vsn.html")
+    (synopsis "Variance stabilization and calibration for microarray data")
+    (description
+     "The package implements a method for normalising microarray intensities,
+and works for single- and multiple-color arrays.  It can also be used for data
+from other technologies, as long as they have similar format.  The method uses
+a robust variant of the maximum-likelihood estimator for an
+additive-multiplicative error model and affine calibration.  The model
+incorporates data calibration step (a.k.a.  normalization), a model for the
+dependence of the variance on the mean intensity and a variance stabilizing
+data transformation.  Differences between transformed intensities are
+analogous to \"normalized log-ratios\".  However, in contrast to the latter,
+their variance is independent of the mean, and they are usually more sensitive
+and specific in detecting differential transcription.")
+    (license license:artistic2.0)))
+
 (define-public r-xvector
   (package
     (name "r-xvector")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 0dd362c8ee..d133764963 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9108,42 +9108,6 @@ proteowizard library for mzML and mzIdentML.  The netCDF reading code has
 previously been used in XCMS.")
     (license license:artistic2.0)))
 
-(define-public r-vsn
-  (package
-    (name "r-vsn")
-    (version "3.58.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "vsn" version))
-       (sha256
-        (base32
-         "0dfrfflidpnphwyqzmmfiz9blfqv6qa09xlwgfabhpfsf3ml2rlb"))))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-affy" ,r-affy)
-       ("r-biobase" ,r-biobase)
-       ("r-ggplot2" ,r-ggplot2)
-       ("r-lattice" ,r-lattice)
-       ("r-limma" ,r-limma)))
-    (native-inputs
-     `(("r-knitr" ,r-knitr))) ; for vignettes
-    (home-page "https://bioconductor.org/packages/release/bioc/html/vsn.html")
-    (synopsis "Variance stabilization and calibration for microarray data")
-    (description
-     "The package implements a method for normalising microarray intensities,
-and works for single- and multiple-color arrays.  It can also be used for data
-from other technologies, as long as they have similar format.  The method uses
-a robust variant of the maximum-likelihood estimator for an
-additive-multiplicative error model and affine calibration.  The model
-incorporates data calibration step (a.k.a.  normalization), a model for the
-dependence of the variance on the mean intensity and a variance stabilizing
-data transformation.  Differences between transformed intensities are
-analogous to \"normalized log-ratios\".  However, in contrast to the latter,
-their variance is independent of the mean, and they are usually more sensitive
-and specific in detecting differential transcription.")
-    (license license:artistic2.0)))
-
 (define-public r-ensembldb
   (package
     (name "r-ensembldb")