summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-04-20 11:03:13 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-04-26 10:26:48 +0200
commit9857abadbabbe29b67a20d18b1e801c1c66c9d6c (patch)
tree9370bb8c24508a7e0a69e60955b3c39257cff4a9 /gnu
parentf57873f20b1f59f7be815e131d8fb1e102e66ae8 (diff)
downloadguix-9857abadbabbe29b67a20d18b1e801c1c66c9d6c.tar.gz
gnu: Add python-pytest-dependency.
* gnu/packages/check.scm (python-pytest-dependency): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 2ad4de55f8..6641a0de58 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2915,3 +2915,26 @@ system.  The code under test requires no modification to work with pyfakefs.")
     (description "Aiounittest is a library that helps write tests using
 asynchronous code in Python (asyncio).")
     (license license:expat)))
+
+(define-public python-pytest-dependency
+  (package
+    (name "python-pytest-dependency")
+    (version "0.5.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "pytest-dependency" version))
+        (sha256
+          (base32
+            "0swl3mxca7nnjbb5grfzrm3fa2750h9vjsha0f2kyrljc6895a62"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-pytest" ,python-pytest)))
+    (home-page
+      "https://github.com/RKrahl/pytest-dependency")
+    (synopsis "Manage dependencies of tests")
+    (description "This pytest plugin manages dependencies of tests.  It allows
+to mark some tests as dependent from other tests.  These tests will then be
+skipped if any of the dependencies did fail or has been skipped.")
+    (license license:asl2.0)))
+