summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-01-18 22:48:04 +0100
committerLudovic Courtès <ludo@gnu.org>2019-01-19 01:26:34 +0100
commit9a0bc7b5aa863eecf1d224d2e976b42e78170d40 (patch)
tree8f5238a4b399b98813cd743b3972722abcef2005 /gnu
parent1d80ec44d30805e6932e0086ca657339b6dc4cd9 (diff)
downloadguix-9a0bc7b5aa863eecf1d224d2e976b42e78170d40.tar.gz
gnu: spacefm: Fix build against glibc 2.28.
* gnu/packages/lxde.scm (spacefm)[source](modules, snippet): New fields.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lxde.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 1f32ec3bb1..a5720ce979 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -6,7 +6,7 @@
 ;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Ison111 <ison111@protonmail.com>
-;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2018, 2019 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -249,7 +249,17 @@ with freedesktop.org standard.")
                     version ".tar.gz"))
               (sha256
                 (base32
-                  "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
+                 "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  (substitute* "src/main.c"
+                    (("#include <sys/types\\.h>" all)
+                     ;; Add missing include for 'major' and 'minor' with glibc
+                     ;; >= 2.28.
+                     (string-append all "\n"
+                                    "#include <sys/sysmacros.h>\n")))
+                  #t))
               (file-name (string-append name "-" version ".tar.gz"))))
     (build-system gnu-build-system)
     (native-inputs `(("pkg-config" ,pkg-config)